[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ezjail] FBSD10 ezjail + iconv problems



Hi,

Am 17.03.2014 um 19:53 schrieb Paul Macdonald <paul AT ifdnrg DOT com>:

>>> On FBSD 10 systems upgrading any of several ports that have an iconv dependency (in jails) fails.
>>> 
>>> Any upgrade or install of any port that pulls in iconv leads to:
>>> 
>>> ===>  Building package for libiconv-1.14_2
>>> Creating package /var/ports/basejail/usr/ports/converters/libiconv/work/libiconv-1.14_2.tbz
>>> Registering depends:.
>>> Creating bzip'd tar ball in '/var/ports/basejail/usr/ports/converters/libiconv/work/libiconv-1.14_2.tbz'
>>> tar: lib/libcharset.so: Cannot stat: No such file or directory
>>> tar: lib/libcharset.so.1: Cannot stat: No such file or directory
>>> tar: lib/libiconv.so: Cannot stat: No such file or directory
>>> tar: lib/libiconv.so.3: Cannot stat: No such file or directory
>>> tar: Error exit delayed from previous errors.
>>> pkg_create: make_dist: tar command failed with code 256
>>> 
>>> The same upgrades/install outside the jail work ok.
>> is this on a box you upgraded to FreeBSD 10? I just tried to install php5-iconv which requires converters/libiconv and it built and installed without errors on a fresh FreeBSD 10 jail.
> yes it was an upgrade, i'll try on a jail which was on a fresh 10 install.
> (are there any steps i might have missed on the upgrade, both jail and host have a uname of 10.0)

I don't know anything particular, but you seem not to be using pkgng, is that possible? Are you using portmaster for the install? 

Cheers,

Philip