[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ezjail] ezjail and FreeBSD 10-Release - Jails won't start



On 22.01.14 20:03, Jeff Hinrichs wrote:

> There seems to be a battle going on between ezjail and jail.conf

Well, it's not actually a battle, just a developer who rewrote the jail
tool without putting too much thought into what features are actually
used and needed. Now we're stuck with jail(8) and a jail.conf format
that is very hard to parse and manipulate in shell and where essential
tools to parse and manipulate it are absent from the base system.

> Starting jails: cannot start jail  "shipping.delasco.com
> <http://shipping.delasco.com>": 
> jail: "shipping_delasco_com" already exists

This usually means that the jail has been run by another instance
already, I guess rc.d/jail is responsible. Can you check with jls if
there's really a shipping_delasco_com running?

> -- Trying to "Start by hand"
> [jlh@neptune /]$ /etc/rc.d/jail start shipping.delasco.com
> <http://shipping.delasco.com>
> Starting jails:/etc/rc.d/jail: WARNING: Invalid configuration for
> shipping_delasco_com  (no jail.conf, no hostname, or no path).   Jail
> shipping_delasco_com was ignored.

It might be a little confusing now, but back in the day that would have
meant to just setup all jail config variables and re-run rc.d/jail :(

> Ok, I am lost here.  I've been through the docs, but I've got to be
> missing something.
> Help.

Hope that helps a little. I am lost, too. Clearly development in jail's
core has run astray. I need to come up with something smart before
FreeBSD 11.

  erdgeist