[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ezjail] Ezjail help (fwd)



You might try updating /usr/local/etc/pkgtools.conf with the following lines:

 #   include_env('etc/pkgtools.local')
 #

 ENV['PORTSDIR'] ||= '/usr/ports'
 ENV['PACKAGES'] ||= '/var/ports/packages'
 ENV['PKG_PATH'] ||= ENV['PACKAGES'] + '/All'
 ENV['PKG_BACKUP_DIR'] ||= ENV['PKG_PATH']
 ENV['PORTS_DBDIR'] ||= '/var/db/ports'

 # SANITY_CHECK: boolean (default: true)


On 3/22/07, Dirk Engling <erdgeist AT erdgeist DOT org> wrote:

So that I wont forget. If someone has an idea, please also respond to
Andy.

Thanks

   erdgeist

---------- Forwarded message ----------
Date: Thu, 22 Mar 2007 17:56:29 -0400
From: Andy Duncan <andy AT lakesite DOT net>
To: 'Dirk Engling' <erdgeist AT erdgeist DOT org>
Subject: Ezjail help

Hey Dirk,



Terribly sorry to bother you, but I've asked lots of folks about this
problem and haven't been able to get an answer.  If you're busy, don't
trouble yourself with a response.



Basically, I'm running the latest version of ezjails and am unable to use
portupgrade, even with the defaults set in /etc/make.conf and replicated in
pkgtools.conf.  My pkgdb doesn't work as expected, even though I've run
ezjail-admin update -p in the host OS, along with portsdb -u.  Here are some
of the problems I encounter:



techno# portupgrade -ra

Stale dependency: zziplib-0.10.82_1 <-- pecl-zip-1.0 -- manually run 'pkgdb
-F' to fix, or specify -O to force.

techno# pkgdb -F

--->  Checking the package registry database

techno# portupgrade -ra

Stale dependency: zziplib-0.10.82_1 <-- pecl-zip-1.0 -- manually run 'pkgdb
-F' to fix, or specify -O to force.

techno# portupgrade -ra -O

Fetching the ports index ... fetch: /usr/ports/INDEX-6.bz2: open():
Read-only file system

*** Error code 1



Any suggestions, documentation links or manual references would be much
appreciated!





Have a great day,



Andy Duncan

Lakesite.Net

http://www.lakesite.net/

Tel: 1.423.847.1171

Fax: 1.866.821.1686