[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

minor problems with a new installation



Hi all.

I've installed ezjail on a new FreeBSD 8.0 server, after running it happily on an old 7.2 server for ages. I did the installation by first installing the port, and then copying the (out of date?) port versions of ezjail-admin and ezjail.sh with the latest versions from CVS.

I can make new jails just fine, and I can start and stop jails if I run the ezjail.sh script directly. But the following fails:

[root@base /usr/jails]# ezjail-admin start
Error: Could not find ezjail's rc.d script in EZJAIL_PREFIX/etc/rc.d/.
  You need to type it the long way.


This is despite the fact that EZJAIL_PREFIX is set correctly in my environment:

[root@base ~]# env
EZJAIL_PREFIX=/usr/local/
...

Also, I can't get "ezjail-admin list" to work, even though "jls" works fine:

[root@base /usr/jails]# jls
   JID  IP Address      Hostname                      Path
     3  64.16.195.27    xeny.net                      /usr/jails/www.xeny.net
[root@base /usr/jails]# ezjail-admin list
STA JID  IP              Hostname                       Root Directory
--- ---- --------------- ------------------------------ -------------------------

[root@base /usr/jails]#



And here's a third weird thing: "ezjail-admin console" works when my pwd is my jails directory (/usr/jails) but not otherwise.

Working from /usr/jails:

[root@base /usr/jails]# ezjail-admin console xeny.net
Error: Nothing known about jail xeny.net.
[root@base /usr/jails]# jls
   JID  IP Address      Hostname                      Path
     3  64.16.195.27    xeny.net                      /usr/jails/www.xeny.net
[root@base /usr/jails]# ezjail-admin console www.xeny.net
Last login: Sat Feb  6 19:25:29 on 3
Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents of the University of California. All rights reserved.

FreeBSD 8.0-RELEASE (GENERIC) #0: Sat Nov 21 15:48:17 UTC 2009
...


Broken, from elsewhere:

[root@base ~]# pwd
/root
[root@base ~]# ezjail-admin console www.xeny.net
Error: Nothing known about jail www.xeny.net.



These are not deal-breaking problems, but I'd be very interested to know what I've done wrong.

Thanks

Jason